Gentoo Logo

PEAR-Auth: Potential authentication bypass

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200603-13 / pear-auth
Release Date March 17, 2006
Latest Revision March 17, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-php/PEAR-Auth < 1.2.4 >= 1.2.4 All supported architectures

Related bugreports: #123832

Synopsis

PEAR-Auth did not correctly verify data passed to the DB and LDAP containers, thus allowing to inject false credentials to bypass the authentication.

2.  Impact Information

Background

PEAR-Auth is a PEAR package that provides methods to create a PHP based authentication system.

Description

Matt Van Gundy discovered that PEAR-Auth did not correctly validate data passed to the DB and LDAP containers.

Impact

A remote attacker could possibly exploit this vulnerability to bypass the authentication mechanism by injecting specially crafted input to the underlying storage containers.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PEAR-Auth users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-php/PEAR-Auth-1.2.4"

4.  References



Print

Page updated March 17, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.