Gentoo Logo

Pngcrush: Buffer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200603-18 / pngcrush
Release Date March 21, 2006
Latest Revision March 21, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-gfx/pngcrush < 1.6.2 >= 1.6.2 All supported architectures

Related bugreports: #123286

Synopsis

Pngcrush is vulnerable to a buffer overflow which could potentially lead to the execution of arbitrary code.

2.  Impact Information

Background

Pngcrush is an optimizer for PNG files.

Description

Carsten Lohrke of Gentoo Linux reported that Pngcrush contains a vulnerable version of zlib (GLSA 200507-19).

Impact

By creating a specially crafted data stream, attackers can overwrite data structures for applications that use Pngcrush, resulting in a Denial of Service and potentially arbitrary code execution.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Pngcrush users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/pngcrush-1.6.2"

4.  References



Print

Page updated March 21, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.