Gentoo Logo

Doomsday: Format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200604-05 / doomsday
Release Date April 06, 2006
Latest Revision June 15, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
games-fps/doomsday <= 1.9.0_beta4 >= 1.9.0_beta4 All supported architectures

Related bugreports: #128690

Synopsis

Format string vulnerabilities in Doomsday may lead to the execution of arbitrary code.

2.  Impact Information

Background

Doomsday is a modern gaming engine for popular ID games like Doom, Heretic and Hexen.

Description

Luigi Auriemma discovered that Doomsday incorrectly implements formatted printing.

Impact

A remote attacker could exploit these vulnerabilities to execute arbitrary code with the rights of the user running the Doomsday server or client by sending specially crafted strings.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Doomsday users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-fps/doomsday-1.9.0_beta4"

4.  References



Print

Page updated April 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.