Gentoo Logo

libextractor: Two heap-based buffer overflows

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200605-14 / libextractor
Release Date May 21, 2006
Latest Revision May 21, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libextractor < 0.5.14 >= 0.5.14 All supported architectures

Related bugreports: #133570

Synopsis

libextractor is vulnerable to two heap overflow vulnerabilities which could lead to the execution of arbitrary code.

2.  Impact Information

Background

libextractor is a library used to extract metadata from arbitrary files.

Description

Luigi Auriemma has found two heap-based buffer overflows in libextractor 0.5.13 and earlier: one of them occurs in the asf_read_header function in the ASF plugin, and the other occurs in the parse_trak_atom function in the Qt plugin.

Impact

By enticing a user to open a malformed file using an application that employs libextractor and its ASF or Qt plugins, an attacker could execute arbitrary code in the context of the application running the affected library.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libextractor users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libextractor-0.5.14"

4.  References



Print

Page updated May 21, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.