Gentoo Logo

WordPress: Arbitrary command execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200606-08 / wordpress
Release Date June 09, 2006
Latest Revision June 10, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/wordpress < 2.0.3 >= 2.0.3 All supported architectures

Related bugreports: #134397

Synopsis

WordPress fails to sufficiently check the format of cached username data.

2.  Impact Information

Background

WordPress is a PHP and MySQL based content management and publishing system.

Description

rgod discovered that WordPress insufficiently checks the format of cached username data.

Impact

An attacker could exploit this vulnerability to execute arbitrary commands by sending a specially crafted username. As of Wordpress 2.0.2 the user data cache is disabled by default.

3.  Resolution Information

Workaround

There are no known workarounds at this time.

Resolution

All WordPress users should upgrade to the latest available version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.3"

4.  References



Print

Page updated June 09, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.