Gentoo Logo

aRts: Privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200606-22 / aRts
Release Date June 22, 2006
Latest Revision June 22, 2006: 01
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
kde-base/arts < 3.5.2-r1 >= 3.5.2-r1, revision >= 3.4.3-r1 All supported architectures

Related bugreports: #135970

Synopsis

The artswrapper part of aRts allows local users to execute arbitrary code with elevated privileges.

2.  Impact Information

Background

aRts is a real time modular system for synthesizing audio used by KDE. artswrapper is a helper application used to start the aRts daemon.

Description

artswrapper fails to properly check whether it can drop privileges accordingly if setuid() fails due to a user exceeding assigned resource limits.

Impact

Local attackers could exploit this vulnerability to execute arbitrary code with elevated privileges. Note that the aRts package provided by Gentoo is only vulnerable if the artswrappersuid USE-flag is enabled.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All aRts users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose kde-base/arts

4.  References



Print

Page updated June 22, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.