Gentoo Logo

PostgreSQL: SQL injection


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200607-04 / postgresql
Release Date July 09, 2006
Latest Revision June 26, 2007: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/postgresql < 8.0.8, < 7.4.13 >= 8.0.8, = 7.4* All supported architectures

Related bugreports: #134168


A flaw in the multibyte character handling allows execution of arbitrary SQL statements.

2.  Impact Information


PostgreSQL is an open source object-relational database management system.


PostgreSQL contains a flaw in the string parsing routines that allows certain backslash-escaped characters to be bypassed with some multibyte character encodings. This vulnerability was discovered by Akio Ishida and Yasuo Ohgaki.


An attacker could execute arbitrary SQL statements on the PostgreSQL server. Be aware that web applications using PostgreSQL as a database back-end might be used to exploit this vulnerability.

3.  Resolution Information


There is no known workaround at this time.


All PostgreSQL users should upgrade to the latest version in the respective branch they are using:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql

Note: While a fix exists for the 7.3 branch it doesn't currently work on Gentoo. All 7.3.x users of PostgreSQL should consider updating their installations to the 7.4 (or higher) branch as soon as possible!

4.  References


Page updated July 09, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.