Gentoo Logo

Apache: Off-by-one flaw in mod_rewrite

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-01 / apache
Release Date August 01, 2006
Latest Revision December 30, 2007: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache < 2.0.58-r2 revision >= 1.3.34-r14, revision >= 1.3.37, >= 2.0.58-r2 All supported architectures

Related bugreports: #141986

Synopsis

A flaw in mod_rewrite could result in a Denial of Service or the execution of arbitrary code.

2.  Impact Information

Background

The Apache HTTP server is one of the most popular web servers on the Internet. The Apache module mod_rewrite provides a rule-based engine to rewrite requested URLs on the fly.

Description

An off-by-one flaw has been found in Apache's mod_rewrite module by Mark Dowd of McAfee Avert Labs. This flaw is exploitable depending on the types of rewrite rules being used.

Impact

A remote attacker could exploit the flaw to cause a Denial of Service or execution of arbitrary code. Note that Gentoo Linux is not vulnerable in the default configuration.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Apache users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose www-servers/apache

4.  References



Print

Page updated August 01, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.