Gentoo Logo

Courier MTA: Denial of Service vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-06 / Courier
Release Date August 04, 2006
Latest Revision August 04, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
mail-mta/courier < 0.53.2 >= 0.53.2 All supported architectures

Related bugreports: #135005

Synopsis

Courier MTA has fixed a DoS issue related to usernames containing a "=" character.

2.  Impact Information

Background

Courier MTA is an integrated mail and groupware server based on open protocols.

Description

Courier MTA has fixed a security issue relating to usernames containing the "=" character, causing high CPU utilization.

Impact

An attacker could exploit this vulnerability by sending a specially crafted email to a mail gateway running a vulnerable version of Courier MTA.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Courier MTA users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-mta/courier-0.53.2"

4.  References



Print

Page updated August 04, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.