Gentoo Logo

pike: SQL injection vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-10 / pike
Release Date August 06, 2006
Latest Revision December 13, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/pike < 7.6.86 >= 7.6.86 All supported architectures

Related bugreports: #136065

Synopsis

A flaw in the input handling could lead to the execution of arbitrary SQL statements in the underlying PostgreSQL database.

2.  Impact Information

Background

Pike is a general purpose programming language, able to be used for multiple tasks.

Description

Some input is not properly sanitised before being used in a SQL statement in the underlying PostgreSQL database.

Impact

A remote attacker could provide malicious input to a pike program, which might result in the execution of arbitrary SQL statements.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All pike users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/pike-7.6.86"

4.  References



Print

Page updated August 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.