Gentoo Logo

fbida: Arbitrary command execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-22 / fbida
Release Date August 23, 2006
Latest Revision August 23, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-gfx/fbida < 2.03-r4 >= 2.03-r4 All supported architectures

Related bugreports: #141684

Synopsis

The fbgs script provided by fbida allows the execution of arbitrary code.

2.  Impact Information

Background

fbida is a collection of image viewers and editors for the framebuffer console and X11. fbgs is a PostScript and PDF viewer for the linux framebuffer console.

Description

Toth Andras has discovered a typographic mistake in the "fbgs" script, shipped with fbida if the "fbcon" and "pdf" USE flags are both enabled. This script runs "gs" without the -dSAFER option, thus allowing a PostScript file to execute, delete or create any kind of file on the system.

Impact

A remote attacker can entice a vulnerable user to view a malicious PostScript or PDF file with fbgs, which may result with the execution of arbitrary code.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All fbida users with the "fbcon" and "pdf" USE flags both enabled should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/fbida-2.03-r4"

4.  References



Print

Page updated August 23, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.