Gentoo Logo

AlsaPlayer: Multiple buffer overflows

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-24 / AlsaPlayer
Release Date August 26, 2006
Latest Revision August 26, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-sound/alsaplayer <= 0.99.76-r3 All supported architectures

Related bugreports: #143402

Synopsis

AlsaPlayer is vulnerable to multiple buffer overflows which could lead to the execution of arbitrary code.

2.  Impact Information

Background

AlsaPlayer is a heavily multithreaded PCM player that tries to utilize ALSA utilities and drivers. As of June 2004, the project is inactive.

Description

AlsaPlayer contains three buffer overflows: in the function that handles the HTTP connections, the GTK interface, and the CDDB querying mechanism.

Impact

An attacker could exploit the first vulnerability by enticing a user to load a malicious URL resulting in the execution of arbitrary code with the permissions of the user running AlsaPlayer.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

AlsaPlayer has been masked in Portage pending the resolution of these issues. AlsaPlayer users are advised to uninstall the package until further notice:

Code Listing 3.1: Resolution

# emerge --ask --unmerge "media-sound/alsaplayer"

4.  References



Print

Page updated August 26, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.