Gentoo Logo

PHP: Arbitary code execution


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-28 / php
Release Date August 29, 2006
Latest Revision March 29, 2008: 05
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/php < 5.1.4-r6 revision >= 4.4.3-r1, revision >= 4.4.4-r4, revision >= 4.4.6, revision >= 4.4.7, revision >= 4.4.8_pre20070816, >= 5.1.4-r6 All supported architectures

Related bugreports: #143126


PHP contains a function that, when used, could allow a remote attacker to execute arbitrary code.

2.  Impact Information


PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.


The sscanf() PHP function contains an array boundary error that can be exploited to dereference a null pointer. This can possibly allow the bypass of the safe mode protection by executing arbitrary code.


A remote attacker might be able to exploit this vulnerability in PHP applications making use of the sscanf() function, potentially resulting in the execution of arbitrary code or the execution of scripted contents in the context of the affected site.

3.  Resolution Information


There is no known workaround at this time.


All PHP 4.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.3-r1"

All PHP 5.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.4-r6"

4.  References


Page updated August 29, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.