Gentoo Logo

AdPlug: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200609-06 / adplug
Release Date September 12, 2006
Latest Revision September 12, 2006: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/adplug < 2.0.1 >= 2.0.1 All supported architectures

Related bugreports: #139593

Synopsis

Multiple heap and buffer overflows exist in AdPlug.

2.  Impact Information

Background

AdPlug is a free, cross-platform, and hardware-independent AdLib sound player library.

Description

AdPlug is vulnerable to buffer and heap overflows when processing the following types of files: CFF, MTK, DMO, U6M, DTM, and S3M.

Impact

By enticing a user to load a specially crafted file, an attacker could execute arbitrary code with the privileges of the user running AdPlug.

3.  Resolution Information

Workaround

There are no known workarounds at this time.

Resolution

All AdPlug users should update to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/adplug-2.0.1"

4.  References



Print

Page updated September 12, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.