Gentoo Logo

PHP: Integer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200610-14 / php
Release Date October 30, 2006
Latest Revision March 29, 2008: 04
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/php < 5.1.6-r6 revision >= 4.4.4-r6, revision >= 4.4.6, revision >= 4.4.7, revision >= 4.4.8_pre20070816, >= 5.1.6-r6 All supported architectures

Related bugreports: #150261

Synopsis

PHP is vulnerable to an integer overflow potentially allowing the remote execution of arbitrary code.

2.  Impact Information

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Description

A flaw in the PHP memory handling routines allows an unserialize() call to be executed on non-allocated memory due to a previous integer overflow.

Impact

An attacker could execute arbitrary code with the rights of the web server user or the user running a vulnerable PHP script.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.6-r6"

All PHP 4.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.4-r6"

4.  References



Print

Page updated October 30, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.