Gentoo Logo

GnuPG: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200612-03 / gnupg
Release Date December 10, 2006
Latest Revision December 10, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-crypt/gnupg < 1.4.6 >= 1.4.6 All supported architectures

Related bugreports: #156476, #156947


GnuPG is vulnerable to a buffer overflow and an erroneous function pointer dereference that can result in the execution of arbitrary code.

2.  Impact Information


The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software.


Hugh Warrington has reported a boundary error in GnuPG, in the "ask_outfile_name()" function from openfile.c: the make_printable_string() function could return a string longer than expected. Additionally, Tavis Ormandy of the Gentoo Security Team reported a design error in which a function pointer can be incorrectly dereferenced.


A remote attacker could entice a user to interactively use GnuPG on a crafted file and trigger the boundary error, which will result in a buffer overflow. They could also entice a user to process a signed or encrypted file with gpg or gpgv, possibly called through another application like a mail client, to trigger the dereference error. Both of these vulnerabilities would result in the execution of arbitrary code with the permissions of the user running GnuPG. gpg-agent, gpgsm and other tools are not affected.

3.  Resolution Information


There is no known workaround at this time.


All GnuPG users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=app-crypt/gnupg-1.4*"

4.  References


Page updated December 10, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.