Gentoo Logo

GNU Radius: Format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200612-17 / gnuradius
Release Date December 14, 2006
Latest Revision December 14, 2006: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-dialup/gnuradius < 1.4 >= 1.4 All supported architectures

Related bugreports: #156376

Synopsis

A format string vulnerabilty has been found in GNU Radius, which could lead to the remote execution of arbitrary code.

2.  Impact Information

Background

GNU Radius is a GNU version of Radius, a server for remote user authentication and accounting.

Description

A format string vulnerability was found in the sqllog function from the SQL accounting code for radiusd. That function is only used if one or more of the "postgresql", "mysql" or "odbc" USE flags are enabled, which is not the default, except for the "server" 2006.1 and 2007.0 profiles which enable the "mysql" USE flag.

Impact

An unauthenticated remote attacker could execute arbitrary code with the privileges of the user running radiusd, which may be the root user. It is important to note that there is no default GNU Radius user for Gentoo systems because no init script is provided with the package.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GNU Radius users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/gnuradius-1.4"

4.  References



Print

Page updated December 14, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.