Gentoo Logo

oftpd: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200701-09 / oftpd
Release Date January 15, 2007
Latest Revision January 15, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-ftp/oftpd < 0.3.7-r3 >= 0.3.7-r3 All supported architectures

Related bugreports: #159178

Synopsis

An assertion in oftpd could lead to a denial of service vulnerability.

2.  Impact Information

Background

oftpd is a small, anonymous only ftp daemon.

Description

By specifying an unsupported address family in the arguments to a LPRT or LPASV command, an assertion in oftpd will cause the daemon to abort.

Impact

Remote, unauthenticated attackers may be able to terminate any oftpd process, denying service to legitimate users.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All oftpd users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-ftp/oftpd-0.3.7-r3"

4.  References



Print

Page updated January 15, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.