Gentoo Logo

SILC Server: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200703-12 / silc-server
Release Date March 14, 2007
Latest Revision March 14, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-im/silc-server < 1.0.2-r1 >= 1.0.2-r1 All supported architectures

Related bugreports: #169599

Synopsis

SILC Server is affected by a Denial of Service vulnerability.

2.  Impact Information

Background

SILC Server is a server for the Secure Internet Live Conferencing (SILC) protocol.

Description

Frank Benkstein discovered a possible NULL pointer dereference in apps/silcd/command.c if a new channel is created without specifying a valid hmac or cipher algorithm name.

Impact

A remote attacker could cause the server to crash, resulting in a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All SILC Server users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-server-1.0.2-r1"


Print

Page updated March 14, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.