Gentoo Logo

Asterisk: SIP Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200703-14 / asterisk
Release Date March 16, 2007
Latest Revision March 16, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/asterisk < 1.2.14-r1 >= 1.2.14-r1, revision >= 1.0.12-r1 All supported architectures

Related bugreports: #169616

Synopsis

Asterisk is vulnerable to Denial of Service in the SIP channel.

2.  Impact Information

Background

Asterisk is an open source implementation of a telephone private branch exchange (PBX).

Description

The MU Security Research Team discovered that Asterisk contains a NULL-pointer dereferencing error in the SIP channel when handling request messages.

Impact

A remote attacker could cause an Asterisk server listening for SIP messages to crash by sending a specially crafted SIP request message.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Asterisk users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose net-misc/asterisk

Note: Asterisk 1.0.x is no longer supported upstream so users should consider upgrading to Asterisk 1.2.x.

4.  References



Print

Page updated March 16, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.