Gentoo Logo

PostgreSQL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200703-15 / postgresql
Release Date March 16, 2007
Latest Revision May 28, 2009: 04
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/postgresql < 8.0.11 >= 8.0.11, revision >= 7.4.17, revision >= 7.4.16, revision >= 7.3.19, revision >= 7.3.13, revision >= 7.3.21, revision >= 7.4.19 All supported architectures

Related bugreports: #165482

Synopsis

PostgreSQL contains two vulnerabilities that could result in a Denial of Service or unauthorized access to certain information.

2.  Impact Information

Background

PostgreSQL is an open source object-relational database management system.

Description

PostgreSQL does not correctly check the data types of the SQL function arguments under unspecified circumstances nor the format of the provided tables in the query planner.

Impact

A remote authenticated attacker could send specially crafted queries to the server that could result in a server crash and possibly the unauthorized reading of some database content or arbitrary memory.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "dev-db/postgresql"

4.  References



Print

Page updated March 16, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.