Gentoo Logo

CUPS: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200703-28 / cups
Release Date March 31, 2007
Latest Revision March 31, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-print/cups < 1.2.9 >= 1.2.9 All supported architectures

Related bugreports: #170881

Synopsis

CUPS incorrectly handles partially-negotiated SSL connections allowing for a Denial of Service.

2.  Impact Information

Background

CUPS provides a portable printing layer for UNIX-based operating systems.

Description

CUPS does not properly handle partially-negotiated SSL connections. Upon receiving a partially-negotiated SSL connection, CUPS no longer accepts further incoming connections, as the initial connection never times out.

Impact

An attacker could partially negotiate an SSL connection with a CUPS server, and cause future connections to that server to fail, resulting in a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All CUPS users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-print/cups-1.2.9"

4.  References



Print

Page updated March 31, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.