Gentoo Logo

Inkscape: Two format string vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200704-10 / Inkscape
Release Date April 16, 2007
Latest Revision April 16, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-gfx/inkscape < 0.45.1 >= 0.45.1 All supported architectures

Related bugreports: #171799

Synopsis

Two format string vulnerabilities have been discovered in Inkscape, allowing for user-assisted execution of arbitrary code.

2.  Impact Information

Background

Inkscape is a vector graphics editor, using Scalable Vector Graphics (SVG) Format.

Description

Kees Cook has discovered two vulnerabilities in Inkscape. The application does not properly handle format string specifiers in some dialog boxes. Inkscape is also vulnerable to another format string error in its Jabber whiteboard protocol.

Impact

A remote attacker could entice a user to open a specially crafted URI, possibly leading to execution of arbitrary code with the privileges of the user running Inkscape.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Inkscape users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/inkscape-0.45.1"

4.  References



Print

Page updated April 16, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.