Gentoo Logo

Courier-IMAP: Remote execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200704-18 / courier-imap
Release Date April 22, 2007
Latest Revision April 23, 2007: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-mail/courier-imap < 4.0.6-r2 >= 4.0.6-r2, < 4.0.0 All supported architectures

Related bugreports: #168196

Synopsis

A vulnerability has been discovered in Courier-IMAP allowing for remote code execution with root privileges.

2.  Impact Information

Background

Courier-IMAP is an IMAP server which is part of the Courier mail system. It provides access only to maildirs.

Description

CJ Kucera has discovered that some Courier-IMAP scripts don't properly handle the XMAILDIR variable, allowing for shell command injection.

Impact

A remote attacker could send specially crafted login credentials to a Courier-IMAP server instance, possibly leading to remote code execution with root privileges.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Courier-IMAP users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-mail/courier-imap-4.0.6-r2"


Print

Page updated April 22, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.