Gentoo Logo

MySQL: Two Denial of Service vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200705-11 / MySQL
Release Date May 08, 2007
Latest Revision May 08, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/mysql < 5.0.38 >= 5.0.38, < 5.0 All supported architectures

Related bugreports: #170126, #171934

Synopsis

Two Denial of Service vulnerabilities have been discovered in MySQL.

2.  Impact Information

Background

MySQL is a popular multi-threaded, multi-user SQL server.

Description

mu-b discovered a NULL pointer dereference in item_cmpfunc.cc when processing certain types of SQL requests. Sec Consult also discovered another NULL pointer dereference when sorting certain types of queries on the database metadata.

Impact

In both cases, a remote attacker could send a specially crafted SQL request to the server, possibly resulting in a server crash. Note that the attacker needs the ability to execute SELECT queries.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All MySQL users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/mysql-5.0.38"

4.  References



Print

Page updated May 08, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.