Gentoo Logo

PostgreSQL: Privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200705-12 / postgresql
Release Date May 10, 2007
Latest Revision May 28, 2009: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/postgresql < 8.0.13 >= 8.0.13, revision >= 7.4.17, revision >= 7.3.19, revision >= 7.3.21, revision >= 7.4.19 All supported architectures

Related bugreports: #175791

Synopsis

PostgreSQL contains a vulnerability that could result in SQL privilege escalation.

2.  Impact Information

Background

PostgreSQL is an open source object-relational database management system.

Description

An error involving insecure search_path settings in the SECURITY DEFINER functions has been reported in PostgreSQL.

Impact

If allowed to call a SECURITY DEFINER function, an attacker could gain the SQL privileges of the owner of the called function.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version and fix their SECURITY DEFINER functions:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "dev-db/postgresql"

In order to fix the SECURITY DEFINER functions, PostgreSQL users are advised to refer to the PostgreSQL documentation: http://www.postgresql.org/docs/techdocs.77

4.  References



Print

Page updated May 10, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.