Gentoo Logo

MadWifi: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200706-04 / madwifi-ng
Release Date June 11, 2007
Latest Revision June 11, 2007: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-wireless/madwifi-ng < 0.9.3.1 >= 0.9.3.1 All supported architectures

Related bugreports: #179532

Synopsis

Multiple vulnerabilities have been discovered in MadWifi, possibly allowing for the execution of arbitrary code or a Denial of Service.

2.  Impact Information

Background

The MadWifi driver provides support for Atheros based IEEE 802.11 Wireless Lan cards.

Description

Md Sohail Ahmad from AirTight Networks has discovered a divison by zero in the ath_beacon_config() function (CVE-2007-2830). The vendor has corrected an input validation error in the ieee80211_ioctl_getwmmparams() and ieee80211_ioctl_getwmmparams() functions(CVE-207-2831), and an input sanitization error when parsing nested 802.3 Ethernet frame lengths (CVE-2007-2829).

Impact

An attacker could send specially crafted packets to a vulnerable host to exploit one of these vulnerabilities, possibly resulting in the execution of arbitrary code with root privileges, or a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All MadWifi users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/madwifi-ng-0.9.3.1"

4.  References



Print

Page updated June 11, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.