Gentoo Logo

Webmin, Usermin: Cross-site scripting vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200707-05 / webmin/usermin
Release Date July 05, 2007
Latest Revision July 05, 2007: 01
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/webmin < 1.350 >= 1.350 All supported architectures
app-admin/usermin < 1.280 >= 1.280 All supported architectures

Related bugreports: #181385

Synopsis

Webmin and Usermin are vulnerable to cross-site scripting vulnerabilities (XSS).

2.  Impact Information

Background

Webmin is a web-based administrative interface for Unix-like systems. Usermin is a simplified version of Webmin designed for use by normal users rather than system administrators.

Description

The pam_login.cgi file does not properly sanitize user input before sending it back as output to the user.

Impact

An unauthenticated attacker could entice a user to browse a specially crafted URL, allowing for the execution of script code in the context of the user's browser and for the theft of browser credentials. This may permit the attacker to login to Webmin or Usermin with the user's permissions.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Webmin users should update to the latest stable version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --verbose --oneshot ">=app-admin/webmin-1.350"

All Usermin users should update to the latest stable version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --verbose --oneshot ">=app-admin/usermin-1.280"

4.  References



Print

Page updated July 05, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.