Gentoo Logo

MadWifi: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200711-09 / madwifi-ng
Release Date November 07, 2007
Latest Revision November 07, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-wireless/madwifi-ng < 0.9.3.3 >= 0.9.3.3 All supported architectures

Related bugreports: #195705

Synopsis

MadWifi does not correctly process beacon frames which can lead to a remotely triggered Denial of Service.

2.  Impact Information

Background

The MadWifi driver provides support for Atheros based IEEE 802.11 Wireless Lan cards.

Description

Clemens Kolbitsch and Sylvester Keil reported an error when processing beacon frames with an overly large "length" value in the "xrates" element.

Impact

A remote attacker could act as an access point and send a specially crafted packet to an Atheros based wireless client, possibly resulting in a Denial of Service (kernel panic).

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All MadWifi users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/madwifi-ng-0.9.3.3"

4.  References



Print

Page updated November 07, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.