Gentoo Logo

Gallery: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200802-04 / gallery
Release Date February 11, 2008
Latest Revision February 11, 2008: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/gallery < 2.2.4 >= 2.2.4, < 2.0 All supported architectures

Related bugreports: #203217

Synopsis

Multiple vulnerabilities were discovered in Gallery.

2.  Impact Information

Background

Gallery is a web-based application for creating and viewing photo albums.

Description

The Gallery developement team reported and fixed critical vulnerabilities during an internal audit (CVE-2007-6685, CVE-2007-6686, CVE-2007-6687, CVE-2007-6688, CVE-2007-6689, CVE-2007-6690, CVE-2007-6691, CVE-2007-6692, CVE-2007-6693).

Impact

A remote attacker could exploit these vulnerabilities to execute arbitrary code, conduct Cross-Site Scripting and Cross-Site Request Forgery attacks, or disclose sensitive informations.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Gallery users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/gallery-2.2.4"

4.  References



Print

Page updated February 11, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.