Gentoo Logo

SILC: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200804-27 / silc-toolkit silc-client silc-server
Release Date April 24, 2008
Latest Revision April 24, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-im/silc-toolkit < 1.1.7 >= 1.1.7 All supported architectures
net-im/silc-client < 1.1.4 >= 1.1.4 All supported architectures
net-im/silc-server < 1.1.2 >= 1.1.2 All supported architectures

Related bugreports: #212362, #214116, #214812

Synopsis

Multiple vulnerabilities were found in SILC Client, Server, and Toolkit, allowing for Denial of Service and execution of arbitrary code.

2.  Impact Information

Background

SILC (Secure Internet Live Conferencing protocol) Toolkit is a software development kit for use in clients, SILC Server is a communication server, and SILC Client is an IRSSI-based text client.

Description

  • Nathan G. Grennan reported a boundary error in SILC Toolkit within the silc_fingerprint() function in the file lib/silcutil/silcutil.c when passing overly long data, resulting in a stack-based buffer overflow (CVE-2008-1227).
  • A vulnerability has been reported in SILC Server which is caused due to an error in the handling of "NEW_CLIENT" packets that do not contain a nickname (CVE-2008-1429).
  • Ariel Waissbein, Pedro Varangot, Martin Mizrahi, Oren Isacson, Carlos Garcia, and Ivan Arce of Core Security Technologies reported that SILC Client, Server, and Toolkit contain a vulnerability in the silc_pkcs1_decode() function in the silccrypt library (silcpkcs1.c), resulting in an integer underflow, signedness error, and a buffer overflow (CVE-2008-1552).

Impact

A remote attacker could exploit these vulnerabilities to cause a Denial of Service or execute arbitrary code with the privileges of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All SILC Toolkit users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-toolkit-1.1.7"

All SILC Client users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-client-1.1.4"

All SILC Server users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/silc-server-1.1.2"

4.  References



Print

Page updated April 24, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.