Gentoo Logo

Pngcrush: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200805-10 / pngcrush
Release Date May 11, 2008
Latest Revision May 11, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-gfx/pngcrush < 1.6.4-r1 >= 1.6.4-r1 All supported architectures

Related bugreports: #219033

Synopsis

A vulnerability in Pngcrush might result in user-assisted execution of arbitrary code.

2.  Impact Information

Background

Pngcrush is a multi platform optimizer for PNG (Portable Network Graphics) files.

Description

It has been reported that Pngcrush includes a copy of libpng that is vulnerable to a memory corruption (GLSA 200804-15).

Impact

A remote attacker could entice a user to process a specially crafted PNG image, possibly resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Pngcrush users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/pngcrush-1.6.4-r1"

4.  References



Print

Page updated May 11, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.