Gentoo Logo

yelp: User-assisted execution of arbitrary code


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200809-01 / yelp
Release Date September 04, 2008
Latest Revision September 04, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
gnome-extra/yelp < 2.22.1-r2 >= 2.22.1-r2, revision >= 2.20.0-r1 All supported architectures

Related bugreports: #234079


A vulnerability in yelp can lead to the execution of arbitrary code when opening a URI, for example through Firefox.

2.  Impact Information


yelp is the default help browser for GNOME.


Aaron Grattafiori reported a format string vulnerability in the window_error() function in yelp-window.c.


A remote attacker can entice a user to open specially crafted "man:" or "ghelp:" URIs in yelp, or an application using yelp such as Firefox or Evolution, and execute arbitrary code with the privileges of that user.

3.  Resolution Information


There is no known workaround at this time.


All yelp users running GNOME 2.22 should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=gnome-extra/yelp-2.22.1-r2"

All yelp users running GNOME 2.20 should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=gnome-extra/yelp-2.20.0-r1"

4.  References


Page updated September 04, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.