Gentoo Logo

POV-Ray: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200812-15 / povray
Release Date December 14, 2008
Latest Revision December 14, 2008: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
media-gfx/povray < 3.6.1-r4 >= 3.6.1-r4 All supported architectures

Related bugreports: #153538

Synopsis

POV-Ray includes a version of libpng that might allow for the execution of arbitrary code when reading a specially crafted PNG file

2.  Impact Information

Background

POV-Ray is a well known open-source ray tracer.

Description

POV-Ray uses a statically linked copy of libpng to view and output PNG files. The version shipped with POV-Ray is vulnerable to CVE-2008-3964, CVE-2008-1382, CVE-2006-3334, CVE-2006-0481, CVE-2004-0768. A bug in POV-Ray's build system caused it to load the old version when your installed copy of libpng was >=media-libs/libpng-1.2.10.

Impact

An attacker could entice a user to load a specially crafted PNG file as a texture, resulting in the execution of arbitrary code with the permissions of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All POV-Ray users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/povray-3.6.1-r4"

4.  References



Print

Page updated December 14, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.