Gentoo Logo

GnuTLS: Certificate validation error

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200901-10 / gnutls
Release Date January 14, 2009
Latest Revision January 14, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-libs/gnutls < 2.4.1-r2 >= 2.4.1-r2 All supported architectures

Related bugreports: #245850

Synopsis

A certificate validation error in GnuTLS might allow for spoofing attacks.

2.  Impact Information

Background

GnuTLS is an open-source implementation of TLS 1.0 and SSL 3.0.

Description

Martin von Gagern reported that the _gnutls_x509_verify_certificate() function in lib/x509/verify.c trusts certificate chains in which the last certificate is an arbitrary trusted, self-signed certificate.

Impact

A remote attacker could exploit this vulnerability and spoof arbitrary names to conduct Man-In-The-Middle attacks and intercept sensitive information.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.4.1-r2"

4.  References



Print

Page updated January 14, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.