Gentoo Logo

FFmpeg: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200903-33 / ffmpeg gst-plugins-ffmpeg mplayer
Release Date March 19, 2009
Latest Revision March 19, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-video/ffmpeg < 0.4.9_p20090201 >= 0.4.9_p20090201 All supported architectures
media-plugins/gst-plugins-ffmpeg < 0.10.5 >= 0.10.5 All supported architectures
media-video/mplayer < 1.0_rc2_p28450 >= 1.0_rc2_p28450 All supported architectures

Related bugreports: #231831, #231834, #245313, #257217, #257381


Multiple vulnerabilities in FFmpeg may lead to the remote execution of arbitrary code or a Denial of Service.

2.  Impact Information


FFmpeg is a complete solution to record, convert and stream audio and video. gst-plugins-ffmpeg is a FFmpeg based gstreamer plugin which includes a vulnerable copy of FFmpeg code. Mplayer is a multimedia player which also includes a vulnerable copy of the code.


Multiple vulnerabilities were found in FFmpeg:

  • astrange reported a stack-based buffer overflow in the str_read_packet() in libavformat/psxstr.c when processing .str files (CVE-2008-3162).
  • Multiple buffer overflows in libavformat/utils.c (CVE-2008-4866).
  • A buffer overflow in libavcodec/dca.c (CVE-2008-4867).
  • An unspecified vulnerability in the avcodec_close() function in libavcodec/utils.c (CVE-2008-4868).
  • Unspecified memory leaks (CVE-2008-4869).
  • Tobias Klein repoerted a NULL pointer dereference due to an integer signedness error in the fourxm_read_header() function in libavformat/4xm.c (CVE-2009-0385).


A remote attacker could entice a user to open a specially crafted media file, possibly leading to the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.

3.  Resolution Information


There is no known workaround at this time.


All FFmpeg users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/ffmpeg-0.4.9_p20090201"

All gst-plugins-ffmpeg users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-ffmpeg-0.10.5"

All Mplayer users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/mplayer-1.0_rc2_p28450"

4.  References


Page updated March 19, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.