Gentoo Logo

GLib: Execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200904-02 / glib
Release Date April 03, 2009
Latest Revision April 05, 2009: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/glib < 2.18.4-r1 >= 2.18.4-r1, revision >= 2.16.6-r1, < 2 All supported architectures

Related bugreports: #249214

Synopsis

Multiple integer overflows might allow for the execution of arbitrary code when performing base64 conversion.

2.  Impact Information

Background

The GLib is a library of C routines that is used by a multitude of programs.

Description

Diego E. Petteno` reported multiple integer overflows in glib/gbase64.c when converting a long string from or to a base64 representation.

Impact

A remote attacker could entice a user or automated system to perform a base64 conversion via an application using GLib, possibly resulting in the execution of arbitrary code.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GLib 2.18 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/glib-2.18.4-r1"

All GLib 2.16 users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/glib-2.16.6-r1"

4.  References



Print

Page updated April 03, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.