Gentoo Logo

WeeChat: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200904-04 / weechat
Release Date April 04, 2009
Latest Revision April 04, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-irc/weechat < 0.2.6.1 >= 0.2.6.1 All supported architectures

Related bugreports: #262997

Synopsis

A processing error in WeeChat might lead to a Denial of Service.

2.  Impact Information

Background

Wee Enhanced Environment for Chat (WeeChat) is a light and extensible console IRC client.

Description

Sebastien Helleu reported an array out-of-bounds error in the colored message handling.

Impact

A remote attacker could send a specially crafted PRIVMSG command, possibly leading to a Denial of Service (application crash).

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All WeeChat users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-irc/weechat-0.2.6.1"

4.  References



Print

Page updated April 04, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.