Gentoo Logo

acpid: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200905-06 / acpid
Release Date May 24, 2009
Latest Revision May 24, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
sys-power/acpid < 1.0.10 >= 1.0.10 All supported architectures

Related bugreports: #268079

Synopsis

An error in acpid might allow remote attackers to cause a Denial of Service.

2.  Impact Information

Background

acpid is a daemon for the Advanced Configuration and Power Interface (ACPI).

Description

The acpid daemon allows opening a large number of UNIX sockets without closing them, triggering an infinite loop.

Impact

Remote attackers can cause a Denial of Service (CPU consumption and connectivity loss).

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All acpid users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-power/acpid-1.0.10"

4.  References



Print

Page updated May 24, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.