Gentoo Logo

GStreamer plug-ins: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200907-11 / gst-plugins-good gst-plugins-base gst-plugins-libpng
Release Date July 12, 2009
Latest Revision July 12, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/gst-plugins-good < 0.10.14 >= 0.10.14 All supported architectures
media-libs/gst-plugins-base < 0.10.22 >= 0.10.22 All supported architectures
media-plugins/gst-plugins-libpng < 0.10.14-r1 >= 0.10.14-r1 All supported architectures

Related bugreports: #256096, #261594, #272972

Synopsis

Multiple vulnerabilities in multiple GStreamer plug-ins might allow for the execution of arbitrary code.

2.  Impact Information

Background

The GStreamer plug-ins provide decoders to the GStreamer open source media framework.

Description

Multiple vulnerabilities have been reported in several GStreamer plug-ins:

  • Tobias Klein reported two heap-based buffer overflows and an array index error in the qtdemux_parse_samples() function in gst-plugins-good when processing a QuickTime media .mov file (CVE-2009-0386, CVE-2009-0387, CVE-2009-0397).
  • Thomas Hoger of the Red Hat Security Response Team reported an integer overflow that can lead to a heap-based buffer overflow in the gst_vorbis_tag_add_coverart() function in gst-plugins-base when processing COVERART tags (CVE-2009-0586).
  • Tielei Wang of ICST-ERCIS, Peking University reported multiple integer overflows leading to buffer overflows in gst-plugins-libpng when processing a PNG file (CVE-2009-1932).

Impact

A remote attacker could entice a user or automated system using a GStreamer plug-in to process a specially crafted file, resulting in the execution of arbitrary code or a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All gst-plugins-good users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-good-0.10.14"

All gst-plugins-base users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-base-0.10.22"

All gst-plugins-libpng users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-libpng-0.10.14-r1"

4.  References



Print

Page updated July 12, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.