Gentoo Logo

OpenSC: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200908-01 / opensc
Release Date August 01, 2009
Latest Revision August 01, 2009: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/opensc < 0.11.8 >= 0.11.8 All supported architectures

Related bugreports: #260514, #269920

Synopsis

Multiple vulnerabilities were found in OpenSC.

2.  Impact Information

Background

OpenSC provides a set of libraries and utilities to access smart cards.

Description

Multiple vulnerabilities were found in OpenSC:

  • b.badrignans discovered that OpenSC incorrectly initialises private data objects (CVE-2009-0368).
  • Miquel Comas Marti discovered that src/tools/pkcs11-tool.c in pkcs11-tool in OpenSC 0.11.7, when used with unspecified third-party PKCS#11 modules, generates RSA keys with incorrect public exponents (CVE-2009-1603).

Impact

The first vulnerabilty allows physically proximate attackers to bypass intended PIN requirements and read private data objects. The second vulnerability allows attackers to read the cleartext form of messages that were intended to be encrypted.

NOTE: Smart cards which were initialised using an affected version of OpenSC need to be modified or re-initialised. See the vendor's advisory for details.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenSC users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/opensc-0.11.8"

4.  References



Print

Page updated August 01, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.