Gentoo Logo

lighttpd: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201006-17 / lighttpd
Release Date June 03, 2010
Latest Revision June 03, 2010: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/lighttpd < 1.4.25-r1 >= 1.4.25-r1 All supported architectures

Related bugreports: #303213

Synopsis

A processing error in lighttpd might result in a Denial of Service condition.

2.  Impact Information

Background

lighttpd is a lightweight high-performance web server.

Description

Li Ming reported that lighttpd does not properly process packets that are sent overly slow.

Impact

A remote attacker might send specially crafted packets to a server running lighttpd, possibly resulting in a Denial of Service condition via host memory exhaustion.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All lighttpd users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/lighttpd-1.4.25-r1"

4.  References



Print

Page updated June 03, 2010

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.