Gentoo Logo

vsftpd: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201110-07 / vsftpd
Release Date October 10, 2011
Latest Revision October 10, 2011: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-ftp/vsftpd < 2.3.4 >= 2.3.4 All supported architectures

Related bugreports: #357001

Synopsis

A Denial of Service vulnerability was found in vsftpd.

2.  Impact Information

Background

vsftpd is a very secure FTP daemon written with speed, size and security in mind.

Description

A Denial of Service vulnerability was discovered in vsftpd. Please review the CVE identifier referenced below for details.

Impact

A remote authenticated attacker could cause a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All vsftpd users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-ftp/vsftpd-2.3.4"

4.  References



Print

Page updated October 10, 2011

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.