Gentoo Logo

Unbound: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201110-12 / unbound
Release Date October 15, 2011
Latest Revision October 15, 2011: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-dns/unbound < 1.4.10 >= 1.4.10 All supported architectures

Related bugreports: #309117, #368981

Synopsis

Multiple Denial of Service vulnerabilities were found in Unbound.

2.  Impact Information

Background

Unbound is a validating, recursive, and caching DNS resolver.

Description

Multiple vulnerabilities have been discovered in unbound. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could cause a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Unbound users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-dns/unbound-1.4.10"

4.  References



Print

Page updated October 15, 2011

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.