Gentoo Logo

Perl Safe module: Arbitrary Perl code injection

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201111-09 / Safe
Release Date November 20, 2011
Latest Revision November 20, 2011: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
perl-core/Safe < 2.27 >= 2.27 All supported architectures
virtual/perl-Safe < 2.27 >= 2.27 All supported architectures

Related bugreports: #325563

Synopsis

The Safe module for Perl does not properly restrict code, allowing a remote attacker to execute arbitrary Perl code outside of a restricted compartment.

2.  Impact Information

Background

Safe is a Perl module to compile and execute code in restricted compartments.

Description

Unsafe code evaluation prevents the Safe module from properly restricting the code of implicitly called methods on implicitly blessed objects.

Impact

A remote attacker could entice a user to load a specially crafted Perl script, resulting in execution arbitrary Perl code outside of a restricted compartment.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All users of the standalone Perl Safe module should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=perl-core/Safe-2.27"

All users of the Safe module bundled with Perl should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=virtual/perl-Safe-2.27"

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since July 18, 2010. It is likely that your system is already no longer affected by this issue.

4.  References



Print

Page updated November 20, 2011

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.