Gentoo Logo

libvirt: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201202-07 / libvirt
Release Date February 27, 2012
Latest Revision February 27, 2012: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-emulation/libvirt < 0.9.3-r1 >= 0.9.3-r1 All supported architectures

Related bugreports: #358877, #372963, #373991, #386287

Synopsis

Multiple vulnerabilities were found in libvirt, the worst of which might allow guest OS users to read arbitrary files on the host OS.

2.  Impact Information

Background

libvirt is a C toolkit to manipulate virtual machines.

Description

Multiple vulnerabilities have been discovered in libvirt. Please review the CVE identifiers referenced below for details.

Impact

These vulnerabilities allow a remote attacker to cause a Denial of Service condition on the host server or libvirt daemon, or might allow guest OS users to read arbitrary files on the host OS.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libvirt users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-0.9.3-r1"

4.  References



Print

Page updated February 27, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.