Gentoo Logo

Apache HTTP Server: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201206-25 / apache
Release Date June 24, 2012
Latest Revision June 24, 2012: 1
Impact high
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache < 2.2.22-r1 >= 2.2.22-r1 All supported architectures

Related bugreports: #308049, #330195, #380475, #382971, #385859, #389353, #392189, #398761, #401081, #412481

Synopsis

Multiple vulnerabilities were found in Apache HTTP Server.

2.  Impact Information

Background

Apache HTTP Server is one of the most popular web servers on the Internet.

Description

Multiple vulnerabilities have been discovered in Apache HTTP Server. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker might obtain sensitive information, gain privileges, send requests to unintended servers behind proxies, bypass certain security restrictions, obtain the values of HTTPOnly cookies, or cause a Denial of Service in various ways.

A local attacker could gain escalated privileges.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Apache HTTP Server users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/apache-2.2.22-r1"

4.  References



Print

Page updated June 24, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.