Gentoo Logo

logrotate: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201206-36 / logrotate
Release Date June 25, 2012
Latest Revision June 25, 2012: 1
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/logrotate < 3.8.0 >= 3.8.0 All supported architectures

Related bugreports: #356811, #372973

Synopsis

Multiple vulnerabilities were found in logrotate, which could lead to arbitrary system command execution.

2.  Impact Information

Background

logrotate rotates, compresses, and mails system logs.

Description

Multiple vulnerabilities have been discovered in logrotate. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could use this flaw to truncate arbitrary system file, to change file owner or mode on arbitrary system files, to conduct symlink attacks and send arbitrary system files, to execute arbitrary system commands, to cause abort in subsequent logrotate runs, to disclose sensitive information, to execute arbitrary code or cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All logrotate users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-admin/logrotate-3.8.0"

4.  References



Print

Page updated June 25, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.