Gentoo Logo

mod_rpaf: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201209-20 / mod_rpaf
Release Date September 27, 2012
Latest Revision September 27, 2012: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apache/mod_rpaf < 0.6 >= 0.6 All supported architectures

Related bugreports: #432406

Synopsis

A vulnerability in mod_rpaf may result in Denial of Service.

2.  Impact Information

Background

mod_rpaf is a reverse proxy add forward module for backend Apache servers.

Description

An error has been found in the way mod_rpaf handles X-Forwarded-For headers. Please review the CVE identifier referenced below for details.

Impact

A remote attacker could send a specially crafted HTTP header, possibly resulting in a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mod_rpaf users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apache/mod_rpaf-0.6"

4.  References



Print

Page updated September 27, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.