Gentoo Logo

PostgreSQL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201209-24 / PostgreSQL
Release Date September 28, 2012
Latest Revision January 20, 2014: 2
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/postgresql-server < 9.1.5 >= 9.1.5, revision >= 9.0.9, revision >= 8.4.13, revision >= 8.3.20, revision >= 8.4.17, revision >= 8.4.19, revision >= 9.0.13, revision >= 9.0.14, revision >= 9.0.15, revision >= 8.4.14, revision >= 8.4.15, revision >= 8.4.16, revision >= 9.0.16, revision >= 9.0.17 All supported architectures

Related bugreports: #406037, #419727, #431766

Synopsis

Multiple vulnerabilities have been found in PostgreSQL which may allow a remote attacker to conduct several attacks.

2.  Impact Information

Background

PostgreSQL is an open source object-relational database management system.

Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could spoof SSL connections. Furthermore, a remote authenticated attacker could cause a Denial of Service, read and write arbitrary files, inject SQL commands into dump scripts, or bypass database restrictions to execute database functions.

A context-dependent attacker could more easily obtain access via authentication attempts with an initial substring of the intended password.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.1 server users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.1.5"

All PostgreSQL 9.0 server users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.0.9"

All PostgreSQL 8.4 server users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.4.13"

All PostgreSQL 8.3 server users should upgrade to the latest version:

Code Listing 3.4: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.3.20"

4.  References



Print

Page updated September 28, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.